Compliance Platform Down
Incident Report for Tether
Resolved
This incident was resolved at 4:15pm yesterday.
Posted Aug 16, 2023 - 09:27 NZST
Monitoring
Our system is back up again and Tether Tick and Survey tools are back up.

This was down from 3:10pm NZ Time, until 4:15pm.

We will continue to monitor for any issues.
Posted Aug 15, 2023 - 16:22 NZST
Investigating
Currently Tether Tick Certificates and our Survey tools are down. We are currently investigating this issue.
Posted Aug 15, 2023 - 16:10 NZST
This incident affected: Tether Platform (Web App, Tether API).