Tether Android App Crashes
Incident Report for Tether
Resolved
This incident has been resolved. Please ensure you have updated to the latest Tether Android App version (3.1.20)
Posted Oct 13, 2023 - 14:07 NZDT
Monitoring
An updated app is now in the Google Play Store and resolves the Android Crash issue.
Posted Oct 12, 2023 - 17:34 NZDT
Update
An updated and fixed Android app is being published to the Google Play Store. Users should head to the play store to update the apps manually.
Posted Oct 12, 2023 - 17:22 NZDT
Identified
We are currently fixing an issue with Android devices using the Tether mobile app. Launching the latest version of the app causes it to crash. A new release will be available soon for users to download.
Posted Oct 12, 2023 - 13:59 NZDT
This incident affected: Tether Platform (Device Management (Mobile App)).