Power Data Not Displaying
Incident Report for Tether
Postmortem

What happened?

An update from our upstream provider was deployed on a database that was running a different version to their other platforms. The update included some performance fixes which relied on a new database function which was not on the version they had running for our HotDrops.

Deploying this feature broke the read requests to their API - and as such all data looked to be missing from the platform.

How was it fixed?

The database was upgraded to the newer version with the function required for reads. Once this was done the API started returning data again.

What data was lost?

The only data that was lost was during the period the database upgrade was underway - approx 20 minutes, or approx 1-2 hotdrop readings (per hotdrop). The rest of the HotDrop data was saved during the outage window and is available.

What steps are being made to stop this from happening again?

We have been underway with some massive infrastructure changes with HotDrops for the past few months. These changes are moving away from this fragile system and onto a new platform that will be faster and more reliable. This change is due to happen in the second half of this year. More details around timelines will be shared closer to the time.

Posted Jul 01, 2021 - 09:17 NZST

Resolved
This incident has been resolved. Graphs and APIs are displaying data. No data was lost during this outage.
Posted Jun 05, 2021 - 14:38 NZST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2021 - 11:03 NZST
Update
Data is being persisted in the backend, however the APIs are not returning any data to display. We are still diagnosing the issue.
Posted Jun 05, 2021 - 09:30 NZST
Investigating
We are currently investigating Power Devices that are returning zero data in the web app and the Power APIs.
Posted Jun 05, 2021 - 07:00 NZST
This incident affected: Tether Platform (Web App, Tether API).